Frequently Asked Questions

Theme Installation Problem - Fatal Error in functions.php on line xxx
Why am I getting "Fatal error: Can't use function return value in write context in /home/username/public_html//wp-content/themes/attorneypress/functions.php on line XXX" error message every time I tried to activate the theme?

Answer:

This problem is happening because your server has a lower PHP version. All of our
themes have support from PHP version 5.6 and up. This is to have secure installation of your wordpress theme. PHP.net has eneded their support for php 5.4 way back in 2014. Please check - http://php.net/supported-versions.php .

You can change this from cPanel or you can ask your hosting provider to update this for you.

To change follow the steps below:

a) Login to cPanel
b) Then click on "Select PHP Version" under "SOFTWARE" heading

image

c) Then select the PHP version 5.6 or UP and click on "Save".

image

After this is done, try to activate the theme or reload the page which displayed fatal error. You should see that the theme is activated now and you can start customizing or importing data.


 Last updated Tue, Dec 26 2017 8:48pm

Please Wait!

Please wait... it will take a second!